Logo: Relish

  1. Sign in

Project: Vim-flavor

Version constraint

In order to use Vim plugins which are compatible with my configuration,
as a lazy Vim user,
I want to declare desirable versions of Vim plugins.

Note that vim-flavor assumes that plugins follow Semantic Versioning 2.0.0, to determine compatibility of
plugins. See also Philosophy for the details.

Background
Given
a repository "foo" with versions "1.0 1.1 1.2 2.0"
Scenarios
Declare using the latest version of a Vim plugin
Given
a flavorfile with:
flavor '$foo_uri'
When
I run vim-flavor install
Then
it should pass
And
a lockfile is created with:
$foo_uri (2.0)
And
a flavor "$foo_uri" version "2.0" is deployed to "$home/.vim"
Declare using a Vim plugin not older than a specific version
Given
a flavorfile with:
flavor '$foo_uri', '>= 1.1'
When
I run vim-flavor install
Then
it should pass
And
a lockfile is created with:
$foo_uri (2.0)
And
a flavor "$foo_uri" version "2.0" is deployed to "$home/.vim"
Declare using the latest and compatible version of a Vim plugin
Given
a flavorfile with:
flavor '$foo_uri', '~> 1.0'
When
I run vim-flavor install
Then
it should pass
And
a lockfile is created with:
$foo_uri (1.2)
And
a flavor "$foo_uri" version "1.2" is deployed to "$home/.vim"

Last published 4 months ago by kana.